tDiary.org - 日記コミュニケーションを加速する


1.5.2リリース

Last Update: 2003-01-19 18:06:56

tDiary 1.5.2をリリースしました。今回リリースされたのは以下のファイルです。

  • tdiary-1.5.2.tar.gz (基本セット)
  • tdiary-full-1.5.2.tar.gz (フルセット)
  • tdiary-blogkit-1.5.2.tar.gz (Blogkit)

ダウンロードのページからどうぞ。

主な変更点は以下のとおりです。

  • 「長年日記」機能を追加。異なる年の同じ日の日記を同一ページで読むことができます。去年の今ごろ何していたかが一目瞭然です
  • ruby 1.6.8をサポート。1.5.1ではうまく動作しなかった点をあらためました。また、昨日リリースされた1.8.0 preview1での動作も確認しています
  • いくつかの新しいテーマを追加
  • whatsnewプラグインを追加
  • plugin: Pluginクラスにapply_pluginメソッドを追加
  • plugin: add_footer_procを追加。日記の最後で呼び出されるコールバックです
Tags: release
コメント(12) [コメントを投稿する]
NT (2002-12-25 21:10)

「apple_pluginメソッド」になってます。

ただただし (2002-12-25 21:15)

thanks

テッポ (2002-12-26 05:22)

導入しようとしたら disp_referer プラグインが動きませんでしたというか Nora の最新版は escape が escape_ext に変更になってるようで…。

smbd (2002-12-26 09:32)

うちでは動いてますなぁ…<br>Nora を新しく作りましたけど。

きた (2002-12-26 10:38)

noraを正しくインストールするとweb/escape.rbと$ARCH/web/escape_ext.soが存在していて,escape.rbがescape_ext.soをrequireしているハズです.

テッポ (2002-12-26 19:28)

install.rb install した時の状況は確認しました。ちゃんと入りますね。でもFAQに記述された方法では入りませんよ?instal しないで escape.so をコピーするって書いてありますけど。

テッポ (2002-12-26 19:30)

(システムにはインストール出来ない環境なもので…)

きた (2002-12-26 21:53)

なるほど.FAQを更新しました.<br>報告ありがとうございます.

rcn (2002-12-28 00:57)

mod_ruby で使おうとしたら tdiary.rb:984 の file? で security error が出たので、引数の文字列を untaint しました。

こ〜りん (2002-12-30 00:55)

1.5.2のrpm作っておきました.<br>http://kourin.dyndns.org/~kourin/files/tdiary-rpm/<br>kitajさんに作ってもらっていたtdiary-setupに差し替えました.<br>(古いのは消しちゃいました.)

ただただし (2002-12-31 00:12)

ども。入れときます >rcn

はてはて (2003-01-19 18:06)

僕にも使えるかな?


«クリスマステーマが目白押し 最新 1.5.2のRPMとdeb» 編集
Fork me on GitHub