tDiary.org - 日記コミュニケーションを加速する


ふたたび2.0安定版Amazonプラグインの更新

Last Update: 2006-11-26 18:25:59

Amazon.co.jpのHTML構造変更に伴う動作不良が長らく続いていましたが、このたびtDiary 2.1系からAmazon Webサービスを利用したものを移植し、HTML構造の変更に影響を受けないものに置き換えました。

このAmazonプラグインは、近々リリースされるtDiary 2.0.3に同梱されますが、早めに使いたいという方は、CVSから入手してください。置き換えるべきファイルは以下の2つ(日本語環境の場合)です:

2点の非互換がありますので、ご注意ください。2.0系は基本的に非互換を出さない方針ですが、amazon.co.jpのHTMLに今後も追従するのは不可能と判断し、このような決断をしました。ご容赦ください。

  • Ruby 1.6系および1.8.1以前を使っている場合には、別途uconvライブラリが必要です(Ruby 1.8.2以降の場合には同梱のNKFライブラリを使うので支障ありません)。
  • 書影サイズの大中小が変わっています。設定ページから好みのサイズに変更してください。

追記

本プラグインは、tDiary 2.0.3に同梱されました。

Tags: plugin amazon
コメント(4) [コメントを投稿する]
ぶちょ (2006-11-24 22:35)

早速使わせて頂きました。私のサイトはEUCで運用しているのですが、書影のタイトルが文字化けします。ちなみに、tdiary2.0.2 ruby1.8.2です。

ただただし (2006-11-25 14:46)

ひょっとすると、素のRuby 1.8.2はNKFがUTF-8非対応だったかも知れません。uconvを入れてみていただけますか?<br>http://www.yoshidam.net/Ruby_ja.html#uconv

ただただし (2006-11-26 16:27)

↑NKFのUTF-8対応はRuby 1.8.2からでした。ですから動くはずですね。もしかしてNKFが入っていないとか?

ぶちょ (2006-11-26 17:34)

Vine3.2を使っているのですが、どうやら、ruby-1.8.2ではなく、1.8.2preだったようです。uconv入れてみます。


«Amazonプラグインの更新 最新 tDiaryの脆弱性に関する報告(2006-11-26)» 編集
Fork me on GitHub