tDiary.org - 日記コミュニケーションを加速する


socialbuttonプラグインにおけるはてなブックマークボタンのトラッキング拒否について

Last Update: 2012-03-10 21:35:02

現在tDiaryのcontribパッケージでは、各種ソーシャルボタンを日記に埋め込むsocialbuttonプラグインを提供しています:

この中で利用可能になっている「はてなブックマークボタン」において、日記読者に対するプライバシー侵害が引き起こされる問題が指摘されています。詳しくは下記の参考リンクをお読みください:

tDiary開発チームではこの問題に対し、プラグイン内部で使用しているjQueryプラグインへのパッチという形で対処いたしました。現在リポジトリに公開中のバージョンでは、プライバシー侵害を引き起こすトラッキングがされないスクリプトを使うようになっています。socialbuttonプラグインを利用している方は、最新版にアップデートするか、下記のパッチを適用することを推奨します:

Read more...

Tags: plugin

プラグインをUTF-8化する方法

Last Update: 2010-10-27 15:43:49

この記事は開発者向け情報です。

tDiaryは2.3から文字コードを全言語でUTF-8に変更しました。これにともない、プラグインなどが出力するテキストもUTF-8にしなくてはなりません。標準添付やcontribに含まれるプラグインはすべてUTF-8を出力するようになっていますが、自作プラグインなどはそれぞれで対応しなくてはいけません。

以下にUTF-8化のための手法について簡単に述べます。もちろん、すべてのプラグインに当てはまるわけではないので、特別なことをしているプラグインは個別に特別な処理が必要になるでしょう。

Read more...

Tags: dev plugin 2.3
コメント(1) [コメントを投稿する]

たくみ [誤) nkf -Ew hoge.rb.euc-jp hoge.rb 正) nkf -Ew hoge.rb.euc-..]


ツッコミ抜きのフィード(RSS)も生成しましょう

Last Update: 2011-11-03 17:48:05

すでに多くの方はmakerssプラグインを使ってフィード(RSS)を配信していると思います。

tDiaryが生成するフィードの最大の特徴は、ツッコミも1つの記事として生成する点です。ツッコミによるコミュニケーションを重視するtDiaryならではの機能ですが、残念なことにツッコミは読みたくないという読者がいるのも確かです。

tDiary 2.2では、従来のツッコミ入りフィードに加え、ツッコミ抜きのフィードも生成できるようになっています。幅広い読者のニーズに応えるため、ぜひツッコミ抜きフィードも生成してあげましょう。

Read more...

Tags: plugin

ふたたび2.0安定版Amazonプラグインの更新

Last Update: 2006-11-26 18:25:59

Amazon.co.jpのHTML構造変更に伴う動作不良が長らく続いていましたが、このたびtDiary 2.1系からAmazon Webサービスを利用したものを移植し、HTML構造の変更に影響を受けないものに置き換えました。

このAmazonプラグインは、近々リリースされるtDiary 2.0.3に同梱されますが、早めに使いたいという方は、CVSから入手してください。置き換えるべきファイルは以下の2つ(日本語環境の場合)です:

2点の非互換がありますので、ご注意ください。2.0系は基本的に非互換を出さない方針ですが、amazon.co.jpのHTMLに今後も追従するのは不可能と判断し、このような決断をしました。ご容赦ください。

  • Ruby 1.6系および1.8.1以前を使っている場合には、別途uconvライブラリが必要です(Ruby 1.8.2以降の場合には同梱のNKFライブラリを使うので支障ありません)。
  • 書影サイズの大中小が変わっています。設定ページから好みのサイズに変更してください。

追記

本プラグインは、tDiary 2.0.3に同梱されました。

Tags: plugin amazon
コメント(4) [コメントを投稿する]

Before...

ただただし [ひょっとすると、素のRuby 1.8.2はNKFがUTF-8非対応だったかも知れません。uconvを入れてみていただ..]

ただただし [↑NKFのUTF-8対応はRuby 1.8.2からでした。ですから動くはずですね。もしかしてNKFが入っていないとか..]

ぶちょ [Vine3.2を使っているのですが、どうやら、ruby-1.8.2ではなく、1.8.2preだったようです。ucon..]


Amazonプラグインの更新

Last Update: 2006-11-23 15:28:54

このエントリは古くなっています。新しい情報はふたたび2.0安定版Amazonプラグインの更新を参照してください。

2006年9月初旬より、Amazon.co.jpのHTMLフォーマット変更にともない、Amazonプラグインがうまく動作しなくなっています。以下の対応により動作するようになりますので、必要な方はご利用ください。

Read more...

Tags: plugin amazon
コメント(8) [コメントを投稿する]

Before...

なんとなく [Mをとったら書影はでたけど、大きくなった(泣)。]

ただただし [もうHTMLを解析して書影を取得するのはあきらめて、2.1系のものを移植してます。ちょっと待っててくださいな。]

たにぐち [きわめて姑息な手段ですが,例のMを取ったうえ,amazon.rb本体のほうのタグのところ(134行目?)に画像サイズ..]


更新
Fork me on GitHub